Antworten auf aktuelle Fragen

In der WoltLab Scene naht schon bald eine neue WoltLab Suite Core Version auf die einige schon ungeduldig warten.


In den letzten Wochen haben wir einige wiederkehrende Fragen (unteranderem auch bezüglich der neuen WSC Version) zu unseren Produkten bekommen welche wir euch hier so weit es uns bereits möglich ist beantworten möchten.

Ab wann ist ein Update kostenpflichtig / Sind neue Funktionen kostenpflichtig?

Darüber haben wir uns nun sehr lange Gedanken gemacht. Wann sollen wir eine neue Funktion in die bestehende Version integrieren, und wann warten wir auf die nächste Version. Wir erhalten immer wieder gute Vorschläge und Wünsche für unsere Produkte welche wir natürlich - sofern machbar und sinnvoll - auch umsetzen möchten. Auch wenn wir einen Teil davon seit dem WSC 5.4 bereits so handhaben, möchten wir euch heute über unser vorgehen informieren.

Aufbau der Versionen

Dazu ist es erst einmal wichtig zu wissen wie unsere Versionen aufgebaut sind.


Früher haben wir mit jeder WSC Version eine neue Major Version veröffentlicht. Dies erkennt ihr bei älteren Plugins bei denen es bereits eine Version 4.0.0 gibt. Da wir hier nicht immer höhere Nummern generieren wollten haben wir uns vor längerer Zeit entschieden immer pro WSC Version eine eigene Minor Version zu verwenden. Als Beispiel vom Ticketsystem wäre die Version 1.0.X für das WSC 5.4, und die Version 1.1.X für die Version welche mit dem WSC 5.5 kompatibel sein wird.


Damit es für euch kein durcheinander gibt wird bei uns hier im Shop bei jeder Version genau angezeigt für welche WSC Version diese kompatibel ist. Auf Woltlab im Plugin-Store erwähnen wir mit jedem Release ebenfalls die kompatible Version. Wer die aktuellen Paketserver im WSC eingetragen hat, erhält so oder so immer automatisch die korrekte Version angeboten.


Da dies für die Kunden verwirrend sein kann, werden wir nun beginnen alle Versionen nach und nach an das Schema des WoltLab Suite Cores anzupassen. Aus dem Ticketsystem der Version 1.0 wird neu die Version 5.4, eine Version für das WSC 5.5 wird danach entsprechend mit der Version 5.5 geführt.

Bei Erweiterungen zu Plugins welche für mehrere Versionen Kompatibel sind (z.B. Branding-Free Lizenzen) werden wir die Versionsnummern nicht anpassen.

Neue Funktionen

Sofern wir einen Vorschlag für sinnvoll erachten und wir diesen ohne einen kompletten Umbau des Produktes umsetzen können, werden wir diesen jeweils immer ausschliesslich für die aktuelle Version

umsetzen. Diese Umsetzung ist natürlich kostenlos. Sobald WoltLab eine neue Major-Version veröffentlicht und wir das Produkt für die neue Version anpassen wird ein Update auf diese kostenpflichtig werden. Neue Funktionen werden dann normalerweise nur noch für diese Version umgesetzt. Bugfixes werden wir natürlich im Rahmen unserer Support Richtlinien weiterhin auch für die ältere Versionen anbieten.

Werden Updates für das WSC 5.5 angeboten?

Für viele von euch dürfe das sicher die interessanteste Frage sein. Leider können wir euch diese noch nicht abschliessend beantworten. Bisher ist es definitiv das wir unsere Apps wie das Ticketsystem oder die Wissensdatenbank für das WSC 5.5 anpassen werden. Anbei fügen wir euch eine Tabelle mit den aktuellen entscheiden ein. Wir werden diese aktualisieren sobald wir eine definitive Antwort haben.

Produkte welche nicht mehr angepasst werden, werden auch nicht mehr zum Verkauf angeboten.


Produkt Entscheid
Hangman Entscheidung noch ausstehen
Geschenke für Mitglieder Entscheidung noch ausstehen
Protokoll der gelöschten Benutzer
Entscheidung noch ausstehen
Mitgliederliste nach Benutzergruppen
Entscheidung noch ausstehen
Wer hats gelesen Wird für das WSC 5.5 angepasst
Lexicon Erweiterung: Wird nicht für das WSC 5.5 angepasst
Mitgliederliste - Erweiterte Einstellungen Entscheidung noch ausstehen
Smiley Favoriten Entscheidung noch ausstehen
Wichteln Wird nicht für das WSC 5.5 angepasst
Glückskekse Entscheidung noch ausstehen
Erweitertes Aktionsprotokoll Wird für das WSC 5.5 angepasst
Ticketsystem Wird für das WSC 5.5 angepasst
Wissensdatenbank Wird für das WSC 5.5 angepasst

Styles

Mitte des letzten Jahres haben wir angekündigt aus Zeitgründen keine Styles mehr anzubieten. Der Verkauf der bisherigen Styles wurde eingestellt da diese mit der aktuellen Version nicht kompatibel ist. Umso mehr freut es mich euch heute hier verkünden zu dürfen, dass Fabienne wieder Styles für die neuen Versionen anbieten wird. In einer ersten Phase prüfen wir intern welche der alten Styles wir wiederbeleben möchten und für die neue Version anpassen werden. Später möchten wir dann schauen das wir auch mal den ein oder anderen neuen Style veröffentlichen können.

Ein Update eines Styles für eine neue WSC Version geht dabei neu nach den selben Regeln wie für die Plugins und ist somit kostenpflichtig.

Unterstützung von älteren Versionen

Da das WSC 5.5 noch in diesem Jahr erscheinen wird ist es an der Zeit die Unterstützung für ältere Versionen einzustellen damit wir uns auf die neuen Versionen konzentrieren können.

Neu werden wir immer ein Jahr nach dem erscheinen einer neuen Version die Unterstützung der Vorversion beginnen einzustellen.

Dies erfolgt wie bisher jeweils in zwei Etappen.

WSC 5.2 - Erste Etappe bereits 2021 abgelaufen

2. Etappe - 01. April 2022

  • Der Support über das Ticketsystem wird eingestellt
  • Die Versionen welche nur mit dem WSC 5.2 kompatibel sind werden entfernt
  • Der Paketserver für das WSC 5.2 wird entfernt

WSC 5.3

1. Etappe - 01. Mai 2022

  • Der Verkauf der Versionen für das WSC 5.3 wird sowohl hier als auch auf WoltLab eingestellt
  • Neue Versionen werden nicht mehr mit dem WSC 5.3 kompatibel sein
  • Es werden nur noch Sicherheitsupdates veröffentlicht

2. Etappe - 01. Mai 2023

  • Der Support über das Ticketsystem wird eingestellt
  • Die Versionen welche nur mit dem WSC 5.3 kompatibel sind werden entfernt
  • Der Paketserver für das WSC 5.3 wird entfernt

WSC 5.4

1. Etappe - 01. Juni 2023 - ca. ein Jahr nach der Veröffentlichung des WSC 5.5

  • Der Verkauf der Versionen für das WSC 5.4 wird sowohl hier als auch auf WoltLab eingestellt
  • Neue Versionen werden nicht mehr mit dem WSC 5.4 kompatibel sein
  • Es werden nur noch Sicherheitsupdates veröffentlicht

2. Etappe - 01. Mai 2024

  • Der Support über das Ticketsystem wird eingestellt
  • Die Versionen welche nur mit dem WSC 5.4 kompatibel sind werden entfernt
  • Der Paketserver für das WSC 5.4 wird entfernt

Roadmap

Um euch eine bessere Übersicht zu geben welche Fehler oder neuen Funktionen für ein Plugin geplant oder in der Umsetzung sind, haben wir uns entschieden bei jedem Produkt eine Roardmap einzufügen. Sollten wir an einer neuen Version für ein Plugin arbeiten findet ihr jeweils das Tab Roadmap beim entsprechenden Produkt.

Als Beispiel findet ihr beim Ticketsystem (nur sofern an einer neuen Version gearbeitet wird) die Roadmap direkt unter diesem Link: Ticketsystem - beMananas Solutions

Comments 4

  • Kann man die Entscheidungen als Kunde beeinflussen? :P

    • Guten Abend. Bitte entschuldige die späte Antwort. Du meinst das mit den neuen Funktionen? Daran lässt sich nicht wirklich was ändern ;)

    • Nein, ich dachte eher an Produkte die eigentlich auch in der neuen Version brauchbar wären. Wie z. B.: das Wichteln :)

    • Das kann ggf. mit mehr Käufen beeinflusst werden :D

      Die Entscheidung was eingestellt wird treffen wir anhand der Verkaufszahlen. Gerade das Wichteln ist ein Produkt welches sich für eine Weiterentwicklung oder für ein Update kaum lohnt. Aber auch hier ist die Entscheidung noch offen.

      Sad 1